User Forum    :: Powered by YaBB
  « MIDI-OX User Forum - Error opening the dialog in 6.4.8 Beta 7 »
Welcome, Guest. Please Login or Register.
Jun 20th, 2024, 2:09pm


Home Home Help Help Search Search Members Members Login Login Register Register


   MIDI-OX User Forum
   MIDI-OX
   MIDI-OX Beta Bugs
(Moderator: Jamie OConnell)
   Error opening the dialog in 6.4.8 Beta 7
« Previous topic | Next topic »
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print
   Author  Topic: Error opening the dialog in 6.4.8 Beta 7  (Read 2870 times)
Dave_Windsor
Member
**



MIDI-OX Rules!

   


Posts: 18
Error opening the dialog in 6.4.8 Beta 7
« on: Jul 26th, 2002, 10:00am »
Quote Quote Modify Modify

I can't save configurations or snapshots. Every time a system dialog is needed, an error message is displayed.
 
System: w98se-eng lite (!).
Lite means, the windows 95 explorer is used within windows 98se to gain resources. As a consequence, system dialogs are also win95 style.
 
I haven't tried it in a normal w98 installation yet, but it would be a pity if it can't work in w98lite... everything else is working like a charm.
 
Cheers, Dave
 
Note: the PhatMox project is stalled a bit, but I'll continue when I'm less busy. Thanks for all your work!
IP Logged
Jamie OConnell
Administrator
*****






   
WWW Email

Gender: male
Posts: 2027
Re: Error opening the dialog in 6.4.8 Beta 7
« Reply #1 on: Jul 26th, 2002, 9:34pm »
Quote Quote Modify Modify

This was broken in 6.4.8 (Beta 6), but we issued a quick Beta 7 (6.4.9) fix that should be working.  Give it a try...
IP Logged

--Jamie
Music is its own reward.

Dave_Windsor
Member
**



MIDI-OX Rules!

   


Posts: 18
Re: Error opening the dialog in 6.4.8 Beta 7
« Reply #2 on: Jul 27th, 2002, 8:21am »
Quote Quote Modify Modify

That's why I posted it... it's still not working in beta 7. At least not on my w98se-lite setup.
 
Cheers, Dave
 
Edit:
Ah, I see the confusion; I said 6.4.8 beta 7 but ofcourse I meant 6.4.9 beta 7.
« Last Edit: Jul 27th, 2002, 4:37pm by Dave_Windsor » IP Logged
Jamie OConnell
Administrator
*****






   
WWW Email

Gender: male
Posts: 2027
Re: Error opening the dialog in 6.4.8 Beta 7
« Reply #3 on: Jul 28th, 2002, 12:29am »
Quote Quote Modify Modify

Please humour me and check that the About box says that it's version 6.4.9.333 -- the symptoms you mention sound exactly like version 6.4.8.331.  If it is version 6.4.9.333, see if any of the following dialog boxes open, and tell me which ones do and don't:
 
File | Log...  The [...] button => File Open
File | Load Profile...  => File Open
File | Save Profile... =>  File Save As
File | Load Snapshot...  => File Open
File | Save Snapshot... =>  File Save As
Options | Data Mapping... [Load...] => File Open
Options | Data Mapping... [Save...] => File Save As
Options | Patch Mapping... [Load...] => File Open
Options | Patch Mapping... [Save...] => File Save As
Options | Folders...  Any [...] Button => Folder Browser
 
Please tell me what happens: error message? Nothing? Crash?
That will help debug this, if it's still a problem.  Thanks.  
 
It's very difficult to write a program that operates on every version of Windows from XP Professional down to Windows 95 without always going for the lowest common denominator.  
 
We don't always want to punish users with capable systems either, so it may be necessary to eventually drop support for Windows 95.  From what I can tell, Windows 98 - Lite uses Windows 95 components to do its dirty work.  I don't know that this is a problem, but it might be.
« Last Edit: Jul 28th, 2002, 12:43am by Jamie OConnell » IP Logged

--Jamie
Music is its own reward.

Dave_Windsor
Member
**



MIDI-OX Rules!

   


Posts: 18
Re: Error opening the dialog in 6.4.8 Beta 7
« Reply #4 on: Jul 28th, 2002, 4:50am »
Quote Quote Modify Modify

My apologies for my bugreport not being that specific. I run a 98lite/XP dual boot system, and internet is only available on XP. I also had deinstalled beta 7 after I got problems.
 
I have some news on the subject(s).... Smiley
 
The good news:
Everything in beta 7 works now as it should, on w98lite. All dialogs work, and the Data Mapping is saved when closing. So gladly you won't have to drop w95 (w98lite) support.
 
The bad news:
I'm absolutely positive that I used beta 7 (6.4.9.333 ). It's the only beta I ever downloaded. The crucial point here (I guess) is that I installed the beta 7 on a completely clean system. So these are my conlusions:
 
Clean system, after installing Microsoft Windows Installer:
 
1) Install beta 7 -> Errors with dialogs and Data Mapping
versus
2) Install the latest non-beta of midi-ox (6.4.2). Then deinstall midiox through Control Panel -> Add/Remove Programs. Then Install beta 7 -> Everything works as it should.
 
So something must be wrong with the installer. I can't reproduce it, because I don't know what files were left after deinstalling 6.4.2.
 
I can imagine this can be a pita to debug. But maybe by looking at the installer you can see what's the problem. I don't think the w95 part of w98lite is the problem, I think the problems will arise on clean w98 systems as well. I you decide not to solve it, I suggest you keep 6.4.2 available at an 'old versions' section, and mention my workaround.
 
Cheers + thanks for your attention, Dave
IP Logged
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print

« Previous topic | Next topic »


MIDI-OX User Forum » Powered by YaBB 1 Gold - SP 1.3.1!
YaBB © 2000-2003. All Rights Reserved.