User Forum    :: Powered by YaBB
  « MIDI-OX User Forum - The Behringer V-Amp2 Midi usage. »
Welcome, Guest. Please Login or Register.
Jun 30th, 2022, 7:19pm


Home Home Help Help Search Search Members Members Login Login Register Register


   MIDI-OX User Forum
   MIDI-OX
   Questions and Discussion
(Moderator: Jamie OConnell)
   The Behringer V-Amp2 Midi usage.
« Previous topic | Next topic »
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print
   Author  Topic: The Behringer V-Amp2 Midi usage.  (Read 6072 times)
Blueseric
Member
**



MIDI-OX Rules!

   


Gender: male
Posts: 14
The Behringer V-Amp2 Midi usage.
« on: Feb 14th, 2016, 2:54pm »
Quote Quote Modify Modify

Hello Royce or Jamie (both good people,incidently)
okay.......could I ask you for your usual excellent help,please?
Yes.......I have in infamous Behringer V-Amp2 which I have given my grandson, however, I used to be able to save the xys files and then reload new ones in the past.....but I am now unable to get the system to work.....particularly in sending the files into the amp via midi.  It just won't work, despite me setting the buffers in the SysEx view to 32 buffers  each 512 bytes in size and my rechecking and setting 'Delay after F7' TO 120 Milisecs. I do have a new Yamaha UX16 as well as the USB with midi In/Out cables and I'm using a Windows 32 bit XP system. Would you give me some help please.....the Behringer is great and a present and it'd be good to show him how to save and download the available patch files?
Thanks and Best Wishes,
John (Blueseric)  Wink Wink
« Last Edit: Feb 14th, 2016, 2:56pm by Blueseric » IP Logged
Breath
Administrator
*****





   
WWW

Gender: male
Posts: 911
Re: The Behringer V-Amp2 Midi usage.
« Reply #1 on: Feb 14th, 2016, 6:30pm »
Quote Quote Modify Modify

Hi John,
 
Behringer makes a nice little editor that runs under WinXP for the Vamp 2 so you probably don't need to use MidiOx.
 
It looks like a Chinese company, Music Group, has bought out Behringer so the web site looks a little different
http://www.music-group.com/Categories/Behringer/Guitar/Guitar-Effects-Pr ocessors/V-AMP-PRO/p/P0154/downloads
 
Have a look at the  Apps down the bottom of the page.
 
I normally use version 2.0 on my Vamp 2, but version 2 .3 seems to work OK.
Under the File menu there is Import Sysex to load your file into the editor.
 
Feel free to ask again if I have missunderstood what your are trying to do.
 
All the best
Royce  
 
IP Logged
Blueseric
Member
**



MIDI-OX Rules!

   


Gender: male
Posts: 14
Re: The Behringer V-Amp2 Midi usage.
« Reply #2 on: Feb 15th, 2016, 1:49pm »
Quote Quote Modify Modify

Hi Royce,
Thanks for this reply.......I hope all the members realise how helpful you are and have been. I'll check out your advice and be in touch. Cheers,
John
IP Logged
Blueseric
Member
**



MIDI-OX Rules!

   


Gender: male
Posts: 14
Re: The Behringer V-Amp2 Midi usage.
« Reply #3 on: Feb 26th, 2016, 1:44pm »
Quote Quote Modify Modify

Hello again Royce,
well.......think I'll top meself ! I managed to correctly load the driver for the Yamaha ux16 into my XP system.I also tried to use the Behringer special application for the V-Amp2......but, no, I just seem unable to 'receive' the new midi files into my V-Amp2.This is despite doing the checks and following the guide about switching the midi 'on' in my V-Amp2......On the V-Amp2, I set -up as advised, but do not see the lights changing on the UX16 when I send the midi file from my computer, nor does the file register on the Channel 1 (midi channel).I have tried 'accepting' the patch change by pressing the modification button (this is button A or 1 on the V-amp).....
so.......please save a guy's life by throwing some light on this.I am trying to show my grandson how to use the midi on the V-Amp......but......nada ! Thanks and Best Wishes,
John (Blueseric)
IP Logged
Breath
Administrator
*****





   
WWW

Gender: male
Posts: 911
Re: The Behringer V-Amp2 Midi usage.
« Reply #4 on: Feb 26th, 2016, 8:38pm »
Quote Quote Modify Modify

I assume the Vamp editor finds your Vamp via the UX16?
What Channel is the Vamp on (configuration page CTRL+N) ?
 
I just checked with my editor. The File / Import Sysex in the editor only loads a single preset  
(Vamp edit buttons - press A then press A again and current preset sysex should be sent. To save the single preset do a Sysex / Receive Manual Dump...)
I assumed that single and complete sysex could be imported.
My fault, leading you astray. Sorry about that.
 
OK lets step through how you would load a compete sysex file in MidiOx and you can tell me at which step it doesn't work.
 
In Midi Ox you need to have the Midi In Monitor and the MidiOut Monitor and the Midi Port Routings windows visible (View / middle block of options)
In the Midi Port Routing window you should be able to see the ux16 In and Out (Options / Midi devices... )
 
Connect....
Vamp MidiOut -> MidiIn ux16 -> MidiOx  
 
1) Turning any knob on the Vamp (except the Master) should produce a stream of controller messages (CC).
Note that the Volume on the Vamp is probably putting out CC 10  xx   (10 if you are viewing in Hex otherwise it will be 16 - right click in the Monitor window to swap)
 
Now connect....
Vamp MidiIn <- MidiOut ux16 <- MidiOx  
 
2) In the Midi Port Routing window left click drag a connection from the MIDI-OX event port to the ux16 Out port on the right
View/ Control Panel
At the bottom of the Control Panel is the Controller Event - select 16
The channel should match your Vamp.
Left click in the Value box on the bottom right - you can now use the cursor up / down keys to change the value and this sends controller messages out to the Vamp.
The LED light in the Volume should move.  
 
If you are OK to here then the Vamp is chatting to you and you are chatting back to the Vamp.
 
3) Options / Pass Sysex - Check it.  
If this is already checked un-check it and recheck it - there is a bug in MidiOx.
MidiOx remembers the checked state when it closes, but it seems to fail to recognise it when it starts - so you need to remember this each time you start MidiOx.
 
On the Vamp go to Edit mode by pressing both Up and Down preset arrows and press A (see 8.3.1 page 16 of the manual) so it can receive the sysex
 
View / Sysex
On the newly opened Sysex window File / Send Sysex File
Select your sysex file and click OK
You should see the sysex in the Output Monitor
The sysex goes out the MidiOx Event Port like the CC messages sent earlier.
 
Hopefully this should work.  
 
Now start Vamp editor and it should find your Vamp and you can use the editor as well.
 
Note that if you load sysex via MidiOx and the Vamp editor is already running press CTRL+N for Configuration and then just click OK on the Config window and the program will sync up with the changes in the Vamp.
 
If you have any grief, post again.  
 
All the best
Royce
« Last Edit: Feb 26th, 2016, 8:47pm by Breath » IP Logged
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print

« Previous topic | Next topic »


MIDI-OX User Forum » Powered by YaBB 1 Gold - SP 1.3.1!
YaBB © 2000-2003. All Rights Reserved.