User Forum††† :: Powered by YaBB
¬ę MIDI-OX User Forum - MIDI-Ox not receiving signals from Boomerang III ¬Ľ
Welcome, Guest. Please Login or Register.
Jan 29th, 2022, 9:09am


Home Home Help Help Search Search Members Members Login Login Register Register


   MIDI-OX User Forum
   MIDI-OX
   Questions and Discussion
(Moderator: Jamie OConnell)
   MIDI-Ox not receiving signals from Boomerang III
« Previous topic | Next topic »
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print
   Author  Topic: MIDI-Ox not receiving signals from Boomerang III  (Read 283 times)
BrendanFrangers
New Member
*



MIDI-OX Rules!

   


Posts: 6
MIDI-Ox not receiving signals from Boomerang III
« on: Jan 14th, 2022, 9:32pm »
Quote Quote Modify Modify

Coming in here with a bit of a weird one.
 
I'm trying to reverse engineer the MIDI communications of the Boomerang III Phrase Sampler.
The pedal was not designed with full MIDI implementation, although it has MIDI I/O connections, and is only advertised as being able to receive a clock signal along with start and stop commands for the clock.
 
However! The pedal is able to use its MIDI connections to communicate with other Boomerang units in a capacity that they call "Brother-Sync".
In this mode, the multiple pedals are able to sync together and most importantly, they are able to trigger recording of a loop on each other, along with starting and stopping loops.
 
I am wanting to take advantage of this and find a way to send a command to my 'Rang from my pedalboard switcher to trigger the recording of a loop at the same time as a patch change.
 
Clearly there is some kind of signal being sent over MIDI between these units, so I had figured that I could plug the pedal into my MIDI interface and use MIDI-Ox to capture whatever signal is coming out of my 'Rang when I trigger those functions. Then I could send that signal back to my 'Rang to remotely trigger them.
 
Now, with the pedal running from its MIDI out into my Focusrite interface I can see the MIDI indicator flash whenever I press the relevant buttons on the 'Rang. So there is something coming out of it and making it into my computer.
But MIDI-Ox is not showing any incoming signals.
 
When I plug a different MIDI device in, MIDI-Ox picks up the incoming signals with no problem.
 
I am scratching my head on this one. The manufacturer is pretty cagey about any of the communication specs and will only provide information about the MIDI clock functionality.
Supposedly they decided against implementing full MIDI capabilities to require the use of their external controller.
But if they have pedals communicating via a MIDI connection, surely there should be a way to replicate these command signals and send them from a different device.
 
Anybody have any ideas on this?
« Last Edit: Jan 14th, 2022, 9:34pm by BrendanFrangers » IP Logged
Jamie OConnell
Administrator
*****






   
WWW Email

Gender: male
Posts: 2013
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #1 on: Jan 14th, 2022, 9:59pm »
Quote Quote Modify Modify

I took a quick look at the manual on their website.  They say:
 
Quote:

Normal bro-sync operation with 2 or more IIIs (single MIDI cable connection between each III)
With this setup there is a MIDI cable going from the Pedal Linkô Out connector on one III to the
Pedal Linkô In connector on another III. Multiple IIIs can be connected in daisy-chain fashion.

 
Instead of the Pedal Link In connector, attach the cable to your MIDI interface Input (attached to MIDI-OX).  You should be able to see any communication sent from the master device.  It might very well be SysEx so make sure that is enabled
IP Logged

--Jamie
Music is its own reward.

BrendanFrangers
New Member
*



MIDI-OX Rules!

   


Posts: 6
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #2 on: Jan 14th, 2022, 10:16pm »
Quote Quote Modify Modify

Yeah, that is exactly the set up I have.
 
MIDI cable runs from the Pedal Link Out to my interface's MIDI In.
The MIDI indicator on the interface is lighting up when I activate the pedal. So there is a signal coming into the interface, but there is nothing showing up in the MIDI-Ox monitor.
I have switched on Sysex monitoring, but again, no signals received.
 
Not sure what else to try here.
I haven't got any filters on. Do I need to specify a specific channel or anything?
IP Logged
Breath
Administrator
*****





   
WWW

Gender: male
Posts: 896
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #3 on: Jan 16th, 2022, 8:58pm »
Quote Quote Modify Modify

Just to make sure of your set up.
 
You are looking at the 'Input Monitor'  ('View/Input Monitor')?
 
There are two 'filter areas' in MidiOx. Both of them are in the menu 'Options'.
First there is 'MIDI filter'  Make sure nothing is checked except the box 'Display SysEx messages in Monitor'
Click OK
 
The second 'filter' is the 'Options / Data Mapping', but these only apply to Midi data being routed from an input to an output in MidiOx.
As you are only watching the Input Monitor it should no effect.
 
 
Royce
 
IP Logged
BrendanFrangers
New Member
*



MIDI-OX Rules!

   


Posts: 6
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #4 on: Jan 17th, 2022, 1:50am »
Quote Quote Modify Modify

Thanks for the further guidance.
 
I've double checked all of that and I have everything set up correctly, but still there is nothing appearing in the Input Monitor.
 
When I connect a different Midi device, the signal is picked up fine, but I am just not receiving anything from this particular pedal.
 
Is it possible that they have used a different communications protocol in these pedals that can't be interpreted by Midi-Ox?
IP Logged
BrendanFrangers
New Member
*



MIDI-OX Rules!

   


Posts: 6
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #5 on: Jan 17th, 2022, 1:54am »
Quote Quote Modify Modify

I should note that while running a clock signal into the pedal, Midi-Ox will pick up the clock pass thru.
But whatever is being sent by triggering the switches on the pedal does not get picked up by Midi-Ox.
IP Logged
Breath
Administrator
*****





   
WWW

Gender: male
Posts: 896
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #6 on: Jan 18th, 2022, 4:44pm »
Quote Quote Modify Modify

Ok I think that the Boomerang might be using a special serial protocol that is not Midi to chat to other units.
 
If a message doesn't start with a number from 128 (0x80) to 255 (0xFF) then the Midi driver in the PC is likely to ignore it.
So data might come in but not be passed to the Midi part of Windows and so MidiOx isn't going to display it.  
If it is passed to MidiOx the program may think the message is faulty and ignore it, so nothing is displayed.
 
I would suggest you get a copy of Wireshark ( like MidiOx but for all data coming into the USB) and look at the messages coming in the USB from the Boomerang devices.
 
Best of luck
Royce
IP Logged
BrendanFrangers
New Member
*



MIDI-OX Rules!

   


Posts: 6
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #7 on: Jan 19th, 2022, 12:08am »
Quote Quote Modify Modify

Okay, so I actually managed to get some information from the manufacturer and I seem to have got things working how I want them to.
 
I will post this information here for whoever tries to search for it in the future.
 
Boomerang had this to say:
 
"Hereís what I found for you. †
 
Brother Sync (transmit and receive, MIDI SysEx format)
Erase Tap: F0 00 1F 7F 0F 03 F7
Play/Stop All: F0 00 1F 7F 0F 08 F7
LB3 Tap: F0 00 1F 7F 0F 12 F7
Loop3 Start: F0 00 1F 7F 0F 13 F7
 
 
These are the MIDI messages in SysEx format that the Boomerang sends when in Brother Sync with another Boomerang III."
 
Now I will add a note here about some of the functions and how they all work, as my testing has found.
LB3 Tap is the same as using the Loop 3 button on the 'Rang.
With no loop recorded, it will start recording. Sending again will stop recording and begin playback. Sending again will stop playback and any further uses will respectively start and stop playback.
 
Loop3 Start is redundant and shouldn't be needed. It will not start recording if there is no loop currently in Loop 3, it can only be used to start playback of an already recorded loop or stop recording and start playback for a loop currently being recorded. Sending again will not stop playback. Basically useless as LB3 Tap does all this and more.
 
Erase Tap will enter an erase command, allowing you to then select a stopped loop to delete using the buttons on the 'Rang.
Alternatively after sending Erase Tap you can send LB3 Tap or Loop3 Start to select Loop 3 for deletion.
 
Play/Stop All will start or stop playback of all recorded loops.
 
One very important thing to note about these functions is that they will only work if you are starting from a totally blank set up.
If you have any loops recorded, or are in the progress of recording any, that were started by using the buttons directly on the 'Rang, then the 'Rang will not respond to any MIDI signals at all. My guess is that beginning recording directly on a unit designates that unit as the Master.
 
However, if you start from a blank slate and the first loop you record is via MIDI controls, then you can proceed to record other loops directly using the 'Rang, or trigger other functions on the unit, and the MIDI signals will all still function correctly.
 
Anyway, there's a whole bunch of information that will likely never be needed. But at least it is here.
« Last Edit: Jan 19th, 2022, 12:10am by BrendanFrangers » IP Logged
Breath
Administrator
*****





   
WWW

Gender: male
Posts: 896
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #8 on: Jan 19th, 2022, 5:57pm »
Quote Quote Modify Modify

Hi
well that is all Midi.
I don't know why you couldn't see it in MidiOx.
 
Glad you sorted it out.
 
All the best
Royce
IP Logged
BrendanFrangers
New Member
*



MIDI-OX Rules!

   


Posts: 6
Re: MIDI-Ox not receiving signals from Boomerang I
« Reply #9 on: Jan 19th, 2022, 6:55pm »
Quote Quote Modify Modify

Yeah, really odd.
Nothing coming in to Midi-Ox at all, but it can send messages to the 'Rang with no problems and will even receive those messages back when they are passed thru by the 'Rang.
 
Who knows.
At least it is sorted now.
IP Logged
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print

« Previous topic | Next topic »


MIDI-OX User Forum » Powered by YaBB 1 Gold - SP 1.3.1!
YaBB © 2000-2003. All Rights Reserved.