User Forum    :: Powered by YaBB
  « MIDI-OX User Forum - XP Sp2 Home "Cannot load driver" »
Welcome, Guest. Please Login or Register.
Sep 22nd, 2020, 7:14am


Home Home Help Help Search Search Members Members Login Login Register Register


   MIDI-OX User Forum
   MIDI Yoke
   MIDI Yoke Installer Issues
(Moderator: Jamie OConnell)
   XP Sp2 Home "Cannot load driver"
« Previous topic | Next topic »
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print
   Author  Topic: XP Sp2 Home "Cannot load driver"  (Read 4008 times)
OldNick
New Member
*



MIDI-OX Rules!

   


Posts: 5
XP Sp2 Home "Cannot load driver"
« on: Jan 13th, 2006, 7:24pm »
Quote Quote Modify Modify

I am reinstalling MIDI Yoke as I was having a bit of trouble.
 
I dl'd the latest from the site today (14 Jan 2006) and ran the install after uninstalling  
 
using Control Panel Add/Remove Progammmes.
 
The install went as expected ubntil right at the end, when Win said that it could not load  
 
the driver.
 
I checked Windows/system32 and the driver (MidiYoke.drv...not .dll) is there.
 
I rebooted.
 
I uninstalled, cleaned up the registry, and made sure the driver was gone from  
 
windows/system32 (I had to manually remove it)
 
I rebooted
 
I tried again. But although the install works OK. Win still says it cannot load the driver.
 
Can anyone help me with this? I looked through the messages, but did not see this  
 
particular one.  
 
IP Logged
Jamie OConnell
Administrator
*****






   
WWW Email

Gender: male
Posts: 2005
Re: XP Sp2 Home "Cannot load driver"
« Reply #1 on: Jan 15th, 2006, 12:46pm »
Quote Quote Modify Modify

Make sure you download the version for XP (the driver name is myokent.dll after install).  If you still have trouble see this thread: http://www.midiox.com/cgi-bin/yabb/YaBB.pl?board=MYInstall;action=displa y;num=1032034495;start=40
« Last Edit: Jan 15th, 2006, 12:52pm by Jamie OConnell » IP Logged

--Jamie
Music is its own reward.

OldNick
New Member
*



MIDI-OX Rules!

   


Posts: 5
Re: XP Sp2 Home "Cannot load driver"
« Reply #2 on: Jan 15th, 2006, 6:26pm »
Quote Quote Modify Modify

Gah! and D'Oh! Thanks for that. Sorry. In a tizzy at the time.
 
However, to my reason for wanting to reinstall. I am using MIDIYoke, routed via MIDI OX, to drive a Yamaha XG Soft synth SYXG50 from the Yam player, just to try things out.  
 
If I run via MIDI Ox to route the Player to Yoke NT1, then out of MIDI Ox to the Yam SYXG50, just about every activity on the PC causes stutters and pauses in the MIDI playing. If I go straight from the Player to the synth, it's pretty much rock solid.
 
I had the same trouble using say, Win Media Player to run the onboard GS Softsynth.
 
I am runnning XP Home SP2, on a CEel 2.66G Celeron machine, with 512 Mb RAM.
 
Do you have any ideas about how to deal with this? It would cut me up completely if I could not go back to using MYoke/MIDI Ox.
IP Logged
OldNick
New Member
*



MIDI-OX Rules!

   


Posts: 5
Re: XP Sp2 Home "Cannot load driver"
« Reply #3 on: Jan 15th, 2006, 9:16pm »
Quote Quote Modify Modify

Hopefully to avoid mookin abaht, I have also tried Hubi's using your Yoke ports. Same trouble. I have also tried the registry priority entry shown on your site, and I _think_ it may have helped but nowhere nearly stopped the problem.
 
Thanks for any help or advice.
IP Logged
Jamie OConnell
Administrator
*****






   
WWW Email

Gender: male
Posts: 2005
Re: XP Sp2 Home "Cannot load driver"
« Reply #4 on: Jan 16th, 2006, 1:31pm »
Quote Quote Modify Modify

I don't fully understand your situation.  Tell me if this is right or wrong:
 
You are using a software MIDI Player (Yamaha ???) routed Out to MIDI Yoke 1 to MIDI-OX In (MIDI Yoke 1)?  You are routing MIDI-OX Out to MIDI Yoke 2 to Yamaha SYXG50 input (MIDI Yoke 2)?  You get stutter.
 
There is no stutter if:
 
You use a software MIDI Player (Yamaha ???) routed Out to MIDI Yoke 1 to Yamaha SYXG50 (MIDI Yoke 1)?
 
Is that it?
« Last Edit: Jan 16th, 2006, 1:31pm by Jamie OConnell » IP Logged

--Jamie
Music is its own reward.

OldNick
New Member
*



MIDI-OX Rules!

   


Posts: 5
Re: XP Sp2 Home "Cannot load driver"
« Reply #5 on: Jan 17th, 2006, 4:00am »
Quote Quote Modify Modify

Sorry. I forgot to ask for email notification. Missed this.
 
What you describe is not quite it. I may wel not have been clear. I am a bit flummoxed by this.
 
on Jan 16th, 2006, 1:31pm, Jamie OConnell wrote:

You are using a software MIDI Player (Yamaha Huh) routed Out to MIDI Yoke 1 to MIDI-OX In (MIDI Yoke 1)?  You are routing MIDI-OX Out to MIDI Yoke 2 to Yamaha SYXG50 input (MIDI Yoke 2)?  You get stutter.

 
- I am using the Yamaha XGPlayer software to play the SYXG50 softsynth
    - if I send the XGPlayer Out to MIDI Yoke In, then use MIDIOX to supply the SYXG50, then just about _any_ activity causes major stuttering.
  - Player MIDI Out = MYoke NT 1  
  - (MIDIOX)  
      MIDI In = Myoke NT 1  
      MIDI Out = SYXG50  
    - I have tried using the Maple Virtual ports, and I have also tried using Hubis as a router for the MIDIYoke and Maple ports.
    - I have also tried each of these combos to route to the WINXP GS Softsynth. Same trouble.
 
I also tried using the WIN Media Player to play the midis.
 
All of these combos cause stutter. It is not MIDI Ox, or MIDIYoke, or Maple, or the SYXG50 but me, MIDI and XP :-<
 
on Jan 16th, 2006, 1:31pm, Jamie OConnell wrote:

There is no stutter if:
 
You use a software MIDI Player (Yamaha Huh) routed Out to MIDI Yoke 1 to Yamaha SYXG50 (MIDI Yoke 1)?

 
I get no stutter only if I give the XGPlayer direct access (XGPlayer Setup / MIDI OUT = Softsynth)
 
As far as I can tell, there is no way to tell the SYXG50 to accept input from MYoke port 1 directly.  
    - XGPlayer MIDFI Out = MYoke1  
    - Synth MIDI In = MYoke1
There is no MIDI Source setup capability. So I can't try that, so I can't leave a router (Ox, Hubis etc) out of the chain.
 
At this stage, I have no way to try other than softsynths. I do not have a MIDI port set up on my machine. SO it may be softsynths.
 
IP Logged
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print

« Previous topic | Next topic »


MIDI-OX User Forum » Powered by YaBB 1 Gold - SP 1.3.1!
YaBB © 2000-2003. All Rights Reserved.